Southeast Michigan Woodworkers

Gather, share, learn and enjoy with other woodworkers!
It is currently Sun Oct 22, 2017 4:55 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Aug 07, 2017 2:06 pm 
Offline
Journeyman

Joined: Thu Mar 25, 2010 8:33 am
Posts: 63
Has anyone had experience with Sawstop customer service troubleshooting a cartridge failure? My regular brake cartridge was working fine this weekend. I swapped it with the dado break to make a few cuts on Saturday. When I put it back on Sunday, the solid 'replace cartridge' red light was on the saw. I didn't bump it, or do anything else to affect performance. Dado cartridge registers fine so I know it's not the saw/pins on the arbor thingy. I heard somewhere the SS can run a diagnostic to determine the cause of a brake after it fires- wondering if anyone has experience with customer service for a faulty cartridge that doesn't fire. Thanks!


Top
 Profile  
 
PostPosted: Mon Aug 07, 2017 9:15 pm 
Offline
Master

Joined: Tue Aug 05, 2014 9:09 am
Posts: 173
Location: Ypsilanti
It's all too complicated for me.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Forum hosting by ProphpBB | Software by phpBB | Report Abuse | Privacy